因为有需要,想提取视频里的文案,论坛里的都是提取并转为SRT字幕格式的,就自己用易语言写了一个,非常简单。
就是遍历JSON,合并文本而已。



有币的麻烦打赏一下,谢谢。每天每人有2币,不打赏就过期了。
蓝秦云下载地址:

https://wwx.lanzoui.com/i2rhuqzzm9c

使用方法:
第一步:把你的视频,放到剪映PC端里,识别出字幕后,关闭剪映。


第二步:全盘搜索com.lveditor.draft这个文件夹,进到后,会显示一个英文和数字夹杂的文件夹名,再点进去 ,就可以看到含有字幕内容的JSON文件了—–如果你安装剪映时没有修改安装目录,一般是在C盘某个默认路径,路径可以看下面的示意图:
181624u5iddpcpdwj9cjzh
这个是我的剪映字幕文件的路径:
“C:\Users\Administrator\AppData\Local\JianyingPro\User Data\Projects\com.lveditor.draft\


第三步:找到JSON字幕文件后,右键—打开方式—用记事本打开,复制里面的内容到软件上,然后点“写到桌面文本”那个按钮生成文本就行。
会在“D:\ZM\”文件夹下,生成一个文件名为“故事”的TXT文本,考虑到网友们的桌面路径和我的不一样,干脆在软件右侧开了个框,会在右边的框里也生成一份文本,你们直接在右边直接复制出来也行。

181526r6n6se33s6itooi8

下面是源码:

[Lua] 纯文本查看 复制代码
.版本 2

.程序集 窗口程序集_启动窗口
.程序集变量 json, 类_json
.程序集变量 长文本, 文本型

.子程序 _按钮1_被单击
.局部变量 字幕数, 整数型
.局部变量 i, 整数型
.局部变量 文本, 文本型
.局部变量 文件号, 整数型

json.解析 (编辑框1.内容)
字幕数 = json.成员数 (“materials.texts”)

.计次循环首 (字幕数, i)
    文本 = json.取通用属性 (“materials.texts[” + 到文本 (i - 1) + “].content”)
    .判断开始 (长文本 = “”)
        长文本 = 文本

    .判断 (长文本 ≠ “”)
        长文本 = 长文本 + #换行符 + 文本
    .默认

    .判断结束

.计次循环尾 ()
文件号 = 打开文件 (编辑框2.内容, 4, 1)
写文本行 (文件号, 删首尾空 (长文本))
关闭文件 (文件号)
编辑框3.内容 = 长文本

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注